You need help?

08-09-2018 à 23:07:44
Don't hesitate to post your questions / problems in the "help" rubric or contact us by mail contact.alhau@gmail.com

Alhau team.
13-07-2019 à 13:51:46
Hello,
I could activate the connection with my dometicz, but I could not activate the skill in Alexa. When I click on activation I only will be transferred to the Alhau site and my active connection will be displayed. But the skill isn't activated in Alexa. 

Any Idea

Best regards

Ralf
14-07-2019 à 14:22:04
Hello,

Thank you for using ou skill.
To be sure could you confirm us the "activation process" :

1. You created an account on alhau, filled your domoticz connection and got the "Connection is ok" confirmation (seems good in your message)
2. You downloaded the "Alexa mobile app" on your phone and chose the "Alhau" skill
3. You clicked on "activate" then you were re-directed to Alhau website
4. You used your Alhau credentials to log in 
5. You were re-directed to Alexa and the "Skill is activated" message is displayed.

If I have properly understood your message, you didn't manage to reach step 5.
If you did all the process like described, could you send us the "error message" ?
Did you try several times? (Alexa wait for a login answer for a limited time and sometimes our server is a bit too long to answer).
From which country are you trying to connect your Domoticz server?

You can also send us an email your Login/Password and URL to access to your Domoticz server (only read access for security reason)  to contact.alhau@gmail.com.
It would help us to do some tests and check in our server what happens.

Best,

Alhau Team
14-07-2019 à 22:55:08
Hello,
thank you for your fast response. I get it working with your hints. I solved my problem as I describe:
1. I tried to activate with my Safari browser on my MacBook. After trying to install the skill with my Smartphone, the installation works fine. 
2. My second problem was, that Alexa did not find my Domoticz equipment. The problem was, that I only had IPV6 connection from the outside world. I need to use a IPV4 to IPV6 Portmapper, some Alexa libraries do not support IPV6. After I changed this and reconnected the Skill Alexa was able to find my equipment. 

Thank for your work with this skill. 
One last problem is, that Alexa recognizes my blinds as lights, so I can open and close them, but I could not stop them in the middle. And because I do not speak france, its hard to use the forum and the plattform, because everything is in france language. 

Best regards

Ralf
14-07-2019 à 23:48:41
Hey,

We are happy you manage to solve your problems.
1. We ll check the issue on Safari (maybe our website is bugged on it but Alexa test team validate the login process).

2. Concerning the connection with your Domoticz server, Alexa never access directly to it.
Alexa only talk to Alhau and Alhau talk to your server and Alexa (you ca see it as a bridge).
But Alhau is hosted by AWS and the version of the software which run Alhau is forced by AWS.

So the IPV6 pb is probably due to AWS limitation of software configuration.
We ll do some tests, if the problem is on the software side we would be able to fix it.

Concerning the "lights" it's an Alexa limitation.
Alexa do not support blinds, so Alhau convert them to lights.
You can use percentage to set the blind to a position :
- "Alexa set <device name> to 50%" => will set the blind at the middle of it's position.

If you are using a venitian blind and you want to move slates to the middle, we had a special function to stop the slats:
Tells Alexa to open or close the blind and ask alexa to set the blind to 50%. If the blind is a venitian (and only for this type), Alhau will send a "stop" command, and your slats will stop moving.
We don't have better choices for now for venitian blinds because they are not supported by Alexa.

We are sorry for the lack of multilingual support, we are a little team and it takes time to write documentation, fix bugs and work on others projects ;)

Thank you for your feedbacks and keep us informed about your blinds problems.

Best,

Alhau Team
14-07-2019 à 23:52:09
according to this thread:
https://forums.developer.amazon.com/questions/4391/is-ipv6-supported.html

It seems Aws do not support IPV6 access from Lambda (and Alexa skill by the way).
We should Update Alhau documentation to explain it in the login process.
09-04-2020 à 16:52:18
Hi, i write here because the English help section not working.
First of all compliment for the skill and thabks to share it for free, that's amazing.
I would like to ask one thing as possible suggestion: is it possible to introce an option to import inside alexa not all the devices but only some devices?
A possible discrimination could made by importing all devices or only the devices that are setted in domoticz as favorite (using the star in domoticz )
This is very usefull for example to avoid import in alexa such devices that are using for example as dummy device for automation or for domoticz script in lua or dzvents.

The issue is that if i imoort the devices at first time, and then delete the devices that i do not need in alexa, if i need to add a new device, yeelight for example or a new device that i created in domoticz, the skill will not add only the latest sensor, but will add again alla sensor, and i have to delete manually every sensor that i do not need because they are imported again.

So every update i need to delete all sensor that do not want in alexa starting from the beginning.

Is is possible to have this option?
Maybe another solution couod be before import select what i want and what i do not want?

I have more then 100 device... And inside alexa i need just 30-40
Every time that i update the list of device i have to delete devices that i don't need starting fronn a list of 100 devices :(

Thanks!
10-04-2020 à 23:06:58
Hi,

thank you for reaching us.
This option is already possible : You have to create a specific user for Alhau (specific login/password).
Then in your domoticz menu go to "setup">"more option">"edit user".

In the user description line you should have a "set devices" button.
It will open a list with all your device.
You just have to select those you want to be shared with Alexa. Alhau will only manage to discover the devices you choose so Alexa will only see those devices, not all your devices.

Don't hesitate to ask us if you have any problem to configure a specific user.

Take care of you during covid,

Alhau Team
26-09-2020 à 02:54:22
Hello, i am Connect to domoticz but i have nothing selectet vor the user alhau but i get everithing from domoticz( all devices)
I need only selectet devices

The user for alhau has no selectet a but i get all
27-09-2020 à 15:06:42
Hello,

thank you for reaching us.
Don't hesitate to talk with us using your native language (German I guess?)

I wrote an answer in another topic you wrote in the "public" channel, but the topic has any screenshot so my answer was not suitable.
With your screenshot I can see you already created a user in Domoticz.
By default, new users have 0 devices selected.

If you want to "select" one, just click on it and domoticz will move it from the left column (available devices) to the right column (selected devices for this user).
You can use the right arrow on the top-right corner of the left column to select all (move all to the right) if needed.
You can unselect a device by clicking on it to mode it from the right column to the left column.

When you are done, please remove all devices from Alexa and re-launch a new discovery process.
Alexa should display only devices you selected.

Don't hesitate to contact us if you face any problem.

Best,

Alhau Team.